3ds Max

Overview

The NVIDIA Omniverse™ 3ds Max Connector Plug-In offers a simple toolkit for 3DS Max Users to send and live sync their model data to an NVIDIA Omniverse™ Nucleus. This not only gives 3DS Max users a first class renderer through OMNIVERSE® Create apps but also grants the ability to open, edit and sync with any of the NVIDIA Omniverse™ Connect plugins. Now, depending on the use case, 3DS Max users can choose the workflows and pipelines that work best for their needs while maintaining up to date revisions for all downstream consumers of their work.

Supported Versions

The Omniverse 3dsMax connector supports the following versions of 3dsMax.

Version

Windows

Linux CentoOS

Linux Ubuntu

2020

Yes
No
No

2021

Yes
No
No

2022

Yes
No
No

2023

Yes
No
No

User Interface

Signing-In

Once the plug-in is installed, users can sign into an Omniverse server. Users can connect through the main OMNIVERSE® menu item or from the avatar icon on the OMNIVERSE® toolbar.

OMNIVERSE® Panel Connection

Menu Items

Action

Username

Your username

Password

Your Password

Server Information

Server Address

Note

The server address field will store and auto-populate known recent servers.

After the NVIDIA Omniverse™ 3ds Max Connector Plug-In has been loaded and signed in to, users can now sync, open, and export files to Omniverse.

Project Menu

Menu Items

Action

Create New View project

Launches file dialog to set a path and project name for an AEC View Project

Set Existing Project

Launches file dialog to allow user to set currently opened max or USD to file to an existing AEC View Project

Close View Project

Closes connection to the AEC View Project. This will disable Publish to Project menu option
Max OMNIVERSE® Menu Learn more about the AEC Project Workflow on the Omniverse View Portal

USD Menu

Max OMNIVERSE® USD Menu

Menu Items

Action

USD

Menu for various USD actions

Recent USD

Lists recently opened USD assets

Import USD

Imports USD Files to the current USD file

Open USD

User can open a USD file

Save USD

Save the changes only to the current USD file.
Limited functionality with materials. Some Mesh edits and modifiers may trigger a material sync

Link to USD

Links an existing 3DS Max file to an existing USD.
This allows a user to initiate a live connection
without reexporting the USD.

Close USD

Closes the USD file and resets the 3DS Max file to a new blank scene.

Help Menu

Max OMNIVERSE® Help Menu

Menu Items

Action

Max Connector Documentation

Links directly to the online documentation

Get Support

Links to online OMNIVERSE® forums for support

Release Notes

Links directly to the online documentation release notes

About

Informs user of the version specific information of
3DS Max OMNIVERSE® Plug-In.

3dsMax Omniverse Toolbar

OMNIVERSE® Panel Connection

Option

Result

Connect to OMNIVERSE®

Connect or disconnect to an OMNIVERSE® Nucleus

Open USD

Opens a USD file locally or on a Nucleus

Save USD

Save the current USD file.

Import USD

Imports a USD file into your current project.

Export USD

Exports current project file as a USD.

Share USD

Copies the location of the USD Files, if on nucleus, this link is shareable with other permitted nucleus users.

Live Sync

Enables real-time “live” editing. See Live Sync for details.

Create Variants

Creates a USD Variant container. See Variants for details.

Settings

Opens the OMNIVERSE® Plugin Settings Panel. See Omniverse Settings for details.

Help

Links to this documentation.

About

Version and Technical Information about the Plugin.

USD Export Browser

Max OMNIVERSE® Export Browser

Items

Action

Navigation Bar

Displays the path to the current directory or file the user
has selected. Users can select any part of the existing path
to directly access that par to the path.

Backward

Users can step to older previous paths.

Forward

Users can step toward current path selections.

To Parent Folder

Navigates to the parent folder, of the currently open folder.

New Folder

Creates a new folder/director at the specified location.

Refresh

Refreshes the content of the browser

OMNIVERSE® File Hierarchy

Users can navigate files on OMNIVERSE® servers or their local PC

Content

Shows the content in the selected part of the hierarchy
Max OMNIVERSE® Export Options

Export Options

Utility

Default Prim

The name of the Default Prim for the exported file. OMNIVERSE® defaults the default Prim to World.

Export Mode

What type of USD to export as.
  • Static

Exports the mesh as a static object

Selection Mode


  • Export All

Exports all the meshes in the scene.
  • Export Selected

Exports the selected mesh(s) in the scene.
  • Visible

Exports all currently visible objects.
  • Move to Origin

If enabled then export the object as if it was normalized at world origin.
  • Cameras

Exports all eligible cameras with in the scene
  • Lights

Exports all eligible lights with in the scene
  • Instances

Instances are exported to USD with enforced compatibility with OMNIVERSE® and Hydra.
This option introduces new xforms into the hierarchy for compatibility.

Batch Export

If checked, takes 1st level nodes in hierarchy and exports those as their own USD, then
references them back to a main USD.

USD Path

If Batch Export is enabled, the child USD files will be placed in a directory by the name defined here.

Also Save 3DS Max File

Will also save a 3DS Max file of the scene to the folder of the USD.

MDL Context

Includes materials on export or not.
  • Default

References the core MDLs when exporting MDL render context
  • Include dependencies

Copies MDL dependencies to the chosen directory. If no directory chosen, uses a default.
  • CSV Mapping File

Writes MDL references to existing location defined in the chosen .csv file
  • Material Swap(.csv)

If Export MDL export option is set to Material CSV map, then the csv file to be used is defined here.
  • Materials Templates

This is where Template MDL files go if they are uploaded. The default value of blank would mean the same directory as the USD file being exported. You can override this with a specific path if desired.
results in fewer files being exported.

USD Preview Surface Context

Exports the materials to a USD Preview Material render context as best as possible.

File Name

Set the name of the USD file you’re creating.

Extension Selector

Currently OMNIVERSE® exports USD (binary) files. (See Note Below)

Note

You can export to USDA (Ascii) format by hard typing the extension .usda on export if exporting to a local drive (not an OMNIVERSE® server).

Checkpoint

Utility

Checkpoints

If using Nucleus server that supports Checkpoint, user can capture the state of the file on export

Description

Description of the Checkpoint. Not required.

USD Import Browser

Max OMNIVERSE® USD Menu

Option

Result

Render Context

Choose the preferred method for displaying Materials in 3DS Max.
None: Materials will be ignored.
MDL: Imported materials will be opened, but limited in functionality
Preview Surface: Imported materials will display using USD Preview Surfaces.

Object Name Collision

Choose what to do if there are naming conflicts with Imported Objects.
Overwrite: Replace the existing object if in conflict.
Skip: Keep the original and discard imported objects if name conflict exists.
Modify: Adjusts names of imported object to avoid name conflicts.

Material Name Collision

Choose what to do if there are naming conflicts with Imported Objects.
Overwrite: Replace existing materials if in conflict.
Skip: Keep the original and discard imported materials if in conflict.
Modify: Adjusts names of imported materials to avoid name conflict.

Note

Known Limitations - Import USD limitation - Does not currently collect imported materials. The original location of the materials will remain at same location unless the scene is re-exported.

Omniverse Settings

Max OMNIVERSE® General Settings

General Settings

Option

Result

Auto sign in on startup

If enabled, 3dsMax will automatically sign in with last known credentials on start up.

Echo Omniverse feedback in script Editor

If enabled, prints feedback to the 3dsmax Script Listener.

Verbose Log

If enabled, printed more detailed feedback about Omniverse during Live-Update.

Enable renaming for invalid and duplicate names

If Enabled, automatically fixes up names that are incompatible with USD, MDL, or Omniverse.
Max OMNIVERSE® Live Settings

Live Settings

Option

Result

Selection Mode

Defines the set of objects that are Live-Update connected

Live Transform Edits

If enabled, transform changes are Live updated

Live Material Edits

If enabled, material edits/assignments are Live updated

Live Camera Edits

If enabled, Camera transforms and parameters are Live updated

Live Light Edits

If enabled, Light transforms and parameters are Live updated

Live Timeline Edits

If enabled, scrubbing the timeline in 3dsMax will send the current frame as the USD file during Live update

Live Modeling

If enabled, modeling changes will be sent during Live Update

Usage

Live Sync

Live Sync

This control toggles on/off Live Updates to a USD file. It can be accessed from the OMNIVERSE® toolbar.

  • Control is only enabled when there is a USD file is currently opened. * The act of exporting a USD file also satisfies this requirement.

  • When Live Sync is turned on, the following should happen: * User is asked if they wish to keep the state of the 3dsmax scene or fetch the USD from OMNIVERSE® as the current state. * Edits from Max are sent to the OMNIVERSE® USD asset. Users can configure * Edits made to the USD file will be synced into 3dsmax during the live session. * User Can modify what types of operations are updated Live from the Omniverse Settings Live Settings panel on the Live tab.

Fetch USD

Note

Known Limitations - Not currently supported for hard disc. Must save file to Omniverse server. Name changes to objects in the scene explorer may not register correctly, change names in modifier panel instead.

Save USD

Save USD saves only the changes that were made to the current USD scene. It is intended to preserve any parts of the file that the user did not modify.

Note

Known Limitations - Original materials may not always be preserved. Some actions trigger material re-export.

Variants

Using Variants

USD Variants
  • Scripted modifier that can be added to any object., though a point helper or group is preferred.

  • Supported by Live mode.

Variant Options

Utility

Picked Variant

The top control is a label that provides the user the current variant marked as the
selected variant.

Variant List


  • Objects in List

Lists all variants that are to be exported with the USD.
  • Selection

The selected variant and its children are made visible.
  • Double Click on selections

Makes that selection your current picked variant and adjusts the label as such.

Add +

Adds selected object to the variants list.

Remove -

Removes the selected item from the variants list. The item below replaces the removed variant
as your selection.

Display Controls


  • Display All

Displays all variants for the Max user.

Creating Variants

In order to create a USD Variant in 3ds Max we use the OMNIVERSE® USD Variants helper added when you installed the OMNIVERSE® 3dsMax Connector.

Setup
  1. In a new scene, create 3 objects (Sphere, Cube, Cone).

  2. Center them on the world origin (0,0,0)

Creating Omniverse Variant Helpers
  1. Now, add the OMNIVERSE® helper. Create Panel > Helpers (tab) > NVIDIA OMNIVERSE® (Drop Down Menu)

  2. Now, click and drag to create a helper volume.

Adding Variants to the Helper
  1. With the Variant Helper Selected, switch over to the Modify Tab.

  2. In your list of modifiers, you should see nvOmniVariants select it.

  3. When Selected the Modifier should display the USD Variants Panel below the Modifier List.

  4. In the USD Variants panel, select the + below the List.

  5. In the Hierarchy/Layer panel, select the Sphere you created in Setup.

  6. In the USD Variants panel, Select the + again.

  7. In the Hierarchy/Layer panel, select the Cube you created in Setup.

  8. In the USD Variants panel, Select the + again.

  9. In the Hierarchy/Layer panel, select the Cone you created in Setup.

  10. Your Variants List should now contain all 3 objects.

Displaying Variants
  1. In the USD Variants Panel, Select and De-Select the show all check box.

  2. Select a variant in the list to display just the variant of your choosing.

Using Variants Video

Export behavior

When exporting a Prop with variants. The items listed by variants and their children should not be considered as objects themselves because they are part of an object with variants.

Materials

Understanding MDLs

When working with the Omniverse, MDL’s are our shader descriptions. Several come pre-installed with your server and will auto-populate upon connecting however there are some specific things to understand about how Maya and MDL interact.

  • The object format for Omniverse is Pixar’s USD format. For more information on USD, see documentation here: Introduction to USD

  • MDLs cannot be directly edited in 3dsMax (but can be created, added to your server and made available in 3dsMax)

  • MDL materials have basic distilling for rendering into the Maya viewport however for true material feedback and rendering, view the asset in Omniverse Create.

MDLs and The Material Editor

The Material Editor will be updated with MDL Materials installed with the Connector. From here, a variety of MDL material types are options to assign to objects.

Compact Material Editor
Create an MDL Material

Create an MDL material through the same create menu as Native 3dsmax materials. Then select the MDL Material from the “General” section and then select the type of MDL to be used.

Create MDL Material
Edit an MDL Material

Selecting an MDL Material will allow you to edit the properties in the properties Panel like any other material in Maya. Only exposed parameters can be edited. Connecting MDL materials in the 3dsMax material graph is not supported.

Select MDL Material

Note

Known Limitation - Editing a parameter on an MDL material does not refresh the rendering of the material in the viewport.

Note

If you use materials native to 3dsMax, on export, the connector attempts to map it to an OmniPBR MDL. This is not a perfect representation of the source material, if possible using MDL from Omniverse, replicates the best.

Add Custom MDL search Paths

Sometimes, a user may want to use a custom MDL that is not a part of the default Omniverse set. Users can add custom MDL search paths. This allows Omniverse to look for additional MDl files. These will be co-located with the other MDL files in the Material Editor.

To edit search paths, simply use the UI in the 3dsMax Omniverse settings dialog. You can get to it from the main menu / Omniverse / Settings.

MDL Search Paths
UDIMs

You can set up UDIM textures using the multi tile node connected to your material. Omniverse will then export as UDIM textures correctly. You can use on native 3dsmax materials or on Omniverse MDL materials.

Note

Known Limitation - UDIM texture will not be renderable in the viewport for MDL materials.

Exporting Materials

There is a variety of ways to export a material from 3dsMax to Omniverse.

  1. Native 3dsmax Materials are mapped to an MDL material on export.
    • This process looks at attributes on your native materials such as Physical Material and maps the parameters as best as possible to an MDL material such as OmniPBR.

    • Note that this process will not capture the native 3dsmax Material Graph.

    • Not all native material types are supported

  2. Vray Materials will be converted to raw MDL materials on export.
    • This process attempts to convert the material graph to MDL so that the essence of the original material is maintained. See Vray with 3dsmax Support Documentation on this page for node support.

  3. MDL Materials
    • If MDL materials were used for materials assignments in your scene, then these materials will be exported to omniverse as is.

  4. CSV Mapping
    • An export option that simple assigns materials already in Omniverse based on how the materials in your scene are named. In this scenario the materials in 3dsMax are simply placeholders for assignment.

  5. USD Preview Surface
    • Every exported file has the opportunity to also add a default render context for USD Preview Surface.

Export Native 3dsMax materials as MDL to Omniverse

Lights

Lights are exported and converted to compatible USD Lights. When a USD file is opened, USD Lights are converted to Native 3dsMax Lights .. Note:: Not all parameters are mapped, only what is compatible with USDlux is converted.

Note

Intensity does not always convert accurately between 3dsMax and USD

Here is the current list of support lights.

Light Group

Light Type

USD Light Type

Standard Lights

Target Directional
Directional
Omni
Target Spotlight
Free Spotlight
- PxrDistantLight
- PxrDistantLight
- PxrDistantLight
- PxrSphereLight
- PxrSphereLight

Photometric Lights

LightscapeLight::TARGET_AREA_TYPE
LightscapeLight::AREA_TYPE
LightscapeLight::TARGET_DISC_TYPE
LightscapeLight::DISC_TYPE
LightscapeLight::TARGET_POINT_TYPE
LightscapeLight::POINT_TYPE
LightscapeLight::TARGET_SPHERE_TYPE
LightscapeLight::SPHERE_TYPE
LightscapeLight::TARGET_CYLINDER_TYPE
LightscapeLight::CYLINDER_TYPE
- PxrRectLight
- PxrRectLight
- Disc
- Disc
- PxrSphereLight
- PxrSphereLight
- PxrSphereLight
- PxrSphereLight
- UsdLuxGeometryLight
- UsdLuxGeometryLight

V-ray Lights

See V-ray section

Scripting

USD Python Binding

USD Python Bindings are available with the installation of the 3dsmax Omniverse Connector.

3DS Max Plugin Script APIs

Currently we only support 3DS Max ms script for accessing the 3dsmax Omniverse Connector.

Connect to server

Check Connection Status

nvOmniverse.IsConnected()

Set User Name and Log in

To make sure that you log in to right server you can call the following script command step by step.

Set User Name

nvOmniverse.UserName = "tester"

Log In

nvOmniverse.ServerUrl = "my-server:1234"

Disconnect

nvOmniverse.Disconnect()

Save Current Logging Information

nvOmniSaveInitSettings()

Connect to Server

nvOmniverse.Connect()

Export Usd

If you want to export the USD to OMNIVERSE®, you can call script command:

nvOmniverse.CreateURL "/Users/aatest/cone.usd"

Exporting Options

We have script API SetOptionVar and GetOptionVar to set and read options. Options are not only used for exporting. They can also be used in other cases. Both option and value are string type and case sensitive. Even if the value is “3” or “true”, they are strings, not integer or bool! And only string “true” is treated as True. Other values will be treated as False.

Setting up Export Mode Types

nvOmniverse.SetOptionVar "export_mode"   "1"

Note

“1” is for Static Prop.

Check Current Value

nvOmniverse.GetOptionVar "export_mode"

Set Export Collection Types

nvOmniverse.SetOptionVar "selection_mode"

Note

“1” is for Export All; “2” for Export Selected; “3” for Export Visible.

Include MDL checkbox

nvOmniverse.SetOptionVar "include_mdl"  "true"

Note

“true” is string and case sensitive.

Copy MDL option drop-down list

nvOmniverse.SetOptionVar "mdl_copy_option" "1"

Note

“1” for Default. “2” for Include Dependencies. “3” for CSV Mapping File.

Include USD Preview Surface

nvOmniverse.SetOptionVar "include_usd_preview_surface" "true"

Camera

nvOmniverse.SetOptionVar "include_camera"  "true"

Light Option

nvOmniverse.SetOptionVar "include_light" "true"

Instance Option

nvOmniverse.SetOptionVar "export_instances"  "true"

Set Axis option

nvOmniverse.SetOptionVar "up_axis"   "2"

Note

“2” is for Z Up which is currently the only option supported.

Split Into Files Option

nvOmniverse.SetOptionVar "enable_split_files"

Also Save 3DS Max

nvOmniverse.SetOptionVar "upload_max_file" "true"

Import Usd

If you want to import one Usd on OMNIVERSE®, you can call this script:

nvOmniverse.OpenURL "/Users/aatest/cone.usd"

Settings Panel Options

Enable Cache

nvOmniverse.SetOptionVar "enable_cache" "true"

Auto Sign In on Startup

nvOmniverse.SetOptionVar "auto_sign_in_on_start"

Echo OMNIVERSE® Feedback in Script Editor

nvOmniverse.SetOptionVar "echo_feedback"

Enable Renaming for Invalid Names and Duplicated Names.

nvOmniverse.SetOptionVar "enable_renaming"

Export Paths

nvOmniverse.SetOptionVar "export_objects_subfolder" "props"

Material Mapping File

nvOmniverse.SetOptionVar "export_material_mapping_file_path" "path to csv file"

Embedded MDL option

nvomniverse.SetOptionVar "omniverse_embed_materials" "true"

Destination Template Path

nvOmniverse.SetOptionVar "export_dest_mdl_template_path" "/Users/aatest/ani"

Third Party

V-Ray™ and 3ds-Max™ to MDL Features and Limitations

3ds-Max Connect supports the conversion of native V-Ray to MDL materials on export. Where possible we support as many of the native V-Ray parameters as we can as well as some common 3dsMax nodes. However in some cases it’s not always achievable. The following table shows the currently support list of shaders along with any limitations in parameter conversion.

Note

Vray 5 is required to utilize the Vray export features of the 3dsMax Omniverse Connector.

Status

Renderer dependent

Renderer Dependent

In-progress

In Progress

Not implemented

Not Implemented

V-Ray

Shader

Status

Limitations and Unsupported Parameters

VrayMtl


Not Implemented
Renderer Dependent
Renderer Dependent
Renderer Dependent
Renderer Dependent
Renderer Dependent

Not Implemented
Renderer Dependent
Renderer Dependent
Renderer Dependent

Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Renderer Dependent
Renderer Dependent
Renderer Dependent

Renderer Dependent
Renderer Dependent

Not Implemented
Not Implemented

Not Implemented
Not Implemented
Renderer Dependent
Not Implemented
Not Implemented
Not Implemented
Not Implemented

Renderer Dependent
Renderer Dependent
Renderer Dependent
Renderer Dependent
Renderer Dependent
Renderer Dependent
Not Implemented
Renderer Dependent
Renderer Dependent
Renderer Dependent
Not Implemented
Reflection
- Fresnel IOR unlocked
- Max depth
- Reflection on back side
- Dim distance
- Dim falloff
- Affect channels
Refraction
- Abbe Number
- Max depth
- Affected channels
- Affected shadows
Fog
- Fog Color
- Fog multiplier
- Fog bias
Translucency
- Translucency
- Scatter coeff
- Fwd/Bck
- Thickness
- Back-side color
- Light multiplier
Self-Illumination
- GI
- Compensate camera exposure
Sheen
- Sheen color
- Sheen glossiness
BRDF
- Type: Phong, Blinn, Ward, GGX
- Use glossiness / Use roughness
- GTR tail falloff
- Anisotropy
- Rotation
- Local axis
- Map channel
Options
- Trace reflections
- Trace refractions
- Cutoff
- Env. Priority
- Double-sided
- Use irradiance map
- Fog system unit scaling
- Effect ID
- Glossy Fresnel
- Preserve energy
- Opacity mode

VrayFastSSS


Renderer Dependent
Renderer Dependent

Renderer Dependent
Renderer Dependent
Renderer Dependent
Renderer Dependent
Specular Layer Parameters
- Trace reflections
- Reflection depth
Options
- Single Scatter
- Refraction depth
- Scatter GI
- Cutoff threshold

VrayNormalMap


Not Implemented
Not Implemented
Basic Parameters
- Map Channel
- Map Rotation

VrayLightMtl


Renderer Dependent
In Progress

Renderer Dependent
Renderer Dependent
Basic Parameters
- Compensate camera exposure
- Displace
Direct Illumination
- On
- Cutoff

VrayBlendMtl



Vray2SidedMtl


Not Implemented
Not Implemented
Basic Parameters
- Multiply by front diffuse
- Force Single sided sub-mtl

VrayDirt



VrayEdgesTex


Not Implemented
Not Implemented

Not Implemented
Not Implemented

Not Implemented
Not Implemented

Not Implemented
Color
- Hidden edges
- Show subtriangles
Width
- World width
- Pixel width
Corners
- Convex only
- Concave only
Width/Radius Multiplier
- Multiplier

Vray Color


Not Implemented
Not Implemented
Color Primaries
- sRGB
- ACEScg

Vray Bitmap



Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented


Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented

Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented
Mapping
Mapping Type
- Angular
- Cubic
- Spherical
- Mirrored Ball
- Mapping source
Ground Projection
Processing
- Render mult.
- Filter mult.
- Interpolation
- Filtering
Crop/Place
- Place
UDIM/UVTILE Preview in material Editor
- RGB Primaries
Coordinates
- Angle U/V/W
- UV/VW/WU
- Blur
- Blur offset
Texture mapping
- Mapping: Vertex map channel
- Mapping Planar from Object XYZ
- Mapping Planar from World XYZ
- Use Real-World Scale
Environment mapping
- Mapping: Spherical env.
- Mapping: Cylindrical env.
- Mapping: Shrink wrap env.
- Mapping: screen

VRayColor2Bump


Not Implemented
Not Implemented

- Height:
- Bump Delta Scale:

VRayBump2Normal


Not Implemented
Not Implemented

- Map Channel:
- Mode: Only Tangent Space Supported

VRayCarpaintMtl



Not Implemented
Not Implemented

- Flake Layer: MDL uses different technique to generate Flakes, therefore these parameters are not used in MDL.
- Flake Layer: Flake Filtering
- Flake Layer: Flake Map Size

3ds-Max

Shader

Limitations and Unsupported Parameters

Noise


Not Implemented


Not Implemented
Not Implemented
Not Implemented
Noise Type
- Fractal
Coordinates
Source
- Vertex Color Channel
- Blur
- Blur Offset

Dent



Not Implemented
Not Implemented
Not Implemented
Coordinates
Source
- Vertex Color Channel
- Blur
- Blur Offset

Mix



Color Correction


Not Implemented
Not Implemented
Not Implemented
Lightness Advanced
- RGB Gain
- RGB Pivot
- RGB Lift / Offset

Bitmap Texture


Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented


Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented

Not Implemented
Not Implemented

Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Coordinates
- Angle U/V/W
- UV/VW/WU
- Blur
- Blur offset
Texture Mapping
- Mapping: Vertex map channel
- Mapping: Planar from Object XYZ
- Mapping: Planar from World XYZ
- Use Real-World Scale
Environment mapping
- Mapping: Spherical env.
- Mapping: Cylindrical env.
- Mapping: Shrink wrap env.
- Mapping: screen
Noise
- On
- Amount
- Level
- Size
- Animate
- Phase
Bitmap Parameters
Filtering
- Pyramidal
- Summed Area
- None
Mono Channel Output
- RGB Intensity
- Alpha
RGB Channel Output
- RGB
- Alpha as Grey
Cropping/Placement
- Apply
- U/V/W/H
Alpha Source
- Image Alpha
- RGB Intensity
- None (opaque)
- Premultiplied alpha
Time
- Start Frame
- Playback Rate
- Sync Frames to Particle Age
End Condition
- Loop
- Ping Pong
- Hold
Output
- Output amount
- Clamp
- RGB offset
- Alpha from RGB Intensity
- RGB level
- Enable Color Map
- Bump Amount

Falloff


Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Falloff Parameters
- Front / Side color/maps
Falloff Type
- Perpendicular/Parallel
- Towards/Away
- Fresnel (F)
- F: Override Material IOR
- F: IOR
- Shadow/Light
- Distance Blend (DB)
- DB: Near Distance
- DB: Far Distance
- DB: Extrapolated
Falloff Direction
- Viewing Direction (cam z)
- Camera X/Y Axis
- Object
- Local X/Y/Z Axis
- World X/Y/Z Axis

Composite



Blend



Top/Bottom


Not Implemented
Not Implemented
Parameters
- Position
- Coordinates

Gradient Ramp


Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented

Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Not Implemented
Coordinates
- Angle U/V/W
- UV/VW/WU
- Blur
- Blur offset
Texture mapping
- Mapping: Vertex map channel
- Mapping: Planar from Object XYZ
- Mapping: Planar from World XYZ
- Use Real-World Scale
Environment mapping
- Mapping: Spherical env.
- Mapping: Cylindrical env.
- Mapping: Shrink wrap env.
- Mapping: screen
Noise
- On
- Amount
- Level
- Size
- Animate
- Phase
Output
- Output amount
- Clamp
- RGB offset
- Alpha from RGB Intensity
- RGB level
- Enable Color Map
- Bump Amount

Standard Output

Not Implemented
Not Implemented
- Output amount, fixed at 1.0
- Enable color map

V-Ray™ Light Support

Lights are mapped to USD Lights on export.

Light Type

USD Light Type

Vray Light (Plane)

- USD Rect Light
Length and Width are interchanged with USD Length and Width. Max will modify these on import/export

Note

V-Ray and the V-Ray logo, Phoenix FD and the Phoenix FD logo are registered trademarks of Chaos Software Ltd. in Bulgaria and/or other countries. Autodesk, the Autodesk logo, 3ds Max are registered trademarks or trademarks of Autodesk, Inc., and/or its subsidiaries and/or affiliates in the USA and/or other countries.

Supported & Unsupported Features

Supported Features

Import/Open (From USD)

  • Geometry
    • Static Meshes

  • Lights
    • Opens USD Lights: Basic support for mapping 3dsmax native lights ( Limited to specific light types) to usd lights.

  • Cameras
    • Opens USD Cameras: Basic support for mapping 3dsmax native cameras ( Limited to specific camera types) to usd cameras.

  • Materials
    • MDL Context

    • USD Preview Surface

Export (To USD)

  • Geometry
    • Static Meshes

  • Lights
    • Export 3dsMax lights: Basic support for mapping 3dsmax native lights ( Limited to specific light types) to usd lights.

  • Cameras
    • Export 3dsMax cameras: Basic support for mapping 3dsmax native cameras ( Limited to specific camera types) to usd cameras.

  • Materials

Other

  • Save USD
    • Allows user to save the current open usd. This saves only the changes made to the usd in place, instead of having to reexport it for faster iterations.

  • Live Edit
    • Transforms: Move rotate and scale assets live.

    • Live Edit Mesh: Live editing the mesh is supported however not all modifiers are supported.

Unsupported Features

General

Geometry

  • Shapes, Splines (are converted to poly)

Materials

  • AML (Autodesk Material Library)

  • UDIM partially unsupported

Maps

  • Bitmap Parameters adjustments

  • Autodesk Bitmaps

Lighting

  • Environment Light mapping is unsupported

  • Sun Positioner mapping is unsupported

  • IES Profiles (Photometric)

  • Atmospheres and Effects for Lights

  • Vray and other non-native 3dsMax lights are not fully supported well

Animation

  • Animation export is in development and not currently supported

  • Skeletal Meshes are not/poorly supported at this time.

Release Notes

103.3

  • Add support for 3dsMax 2023

  • Client Library 1.17.5

  • NOTE - 3dsMax 2019 support will be removed in 3dsMax Omniverse COnnector 104 and above.

103.2

  • Updated Client Library to 1.17.3

103.1

  • Updated Client Library to 1.17.2

  • Improved - VRayCarpaintMtl now supports Flake mapping type and Flake map channel.

  • Improved conversion graphs for native 3dsMax materials to MDL. Physical, Standard, Roughness/Metallic, and Spec/Gloss were all improved. More texture fields are now supported and better logic for determining when MDL controls are turned on/off.

  • Improved 3dsMax UI controls

    • Renamed export option “Split USD to Multiple Files” to “Batch Export.”

    • Moved some options from Settings to the Export dialog.

    • Exposed Colorspace and Alpha mode on MDL materials.

  • Improved - Refactored cameras.

  • Added Payloads as an option for Batch Export.

  • Added Move to Origin on export.

  • Added V-ray Proxy export.

  • Added X-ref export.

  • Added MDL search paths option. User can now specify additional MDL material paths.

  • Added - Prevent connector installation if 3dsMax is not detected.

  • Added - Tooltips throughout 3dsMax Omniverse Connector.

  • Added - Export UDIMs using the multi tile node.

  • Fixed OM-41216 Camera Filmback did not export properly.

  • Fixed OM-42117 only a .project.usd file should be able to be set as s project.

  • Fixed OM-42204 Importing a USD saves them to the scene without pressing Save.

  • Fixed OM-44912 Script error on MDL creation.

  • Fixed OM-42431 V-ray asset is not visible in Create RT mode rendering.

  • Fixed OM-46067 Merging max file doesn’t update texture fields on MDL.

102.4

  • Updated Client Library to 1.16

  • Added VRayColor2Bump support

  • Added VRayBump2Normal support

  • Fixed OM-41600 CSV mapping controls don’t function as expected

  • Fixed OM-41957 Material import not working on specific OmniPBR source

102.3

  • Added Checkpoint auxiliary files

  • Added Live Update options on Setting panel

  • Added support for Vray Light (Plane) export

  • Improved Live Update performance with timeline scrub, and transforming objects

    • Updates are now on Mouse Release

  • Improved VRay material conversions

    • VRayLightMtl intensity has more accurate translation to emissive MDL

    • VRayMtl Reflect/Refract Fresnel IOR more accurate physical translation to MDL

    • VRayMtl improved conversion with opacity maps to MDL

    • VRayBlendMtl improved conversion to MDL

  • Updated Core Materials

  • Fixed OM-40488 Timeline scrub is hitchy

  • Fixed OM-40486 adjust light and camera crash when Live

  • Fixed OM-37288 Materials do not live Sync

  • Fixed OM-36169 Load variant is broken

  • Fixed OM-34406 After deleting objects, duplicated objects don’t always show up in receiving application

  • Fixed OM-25687 Duplicates of Objects made in Create do not always appear in Max during Live

  • Fixed OM-33266 Connectors have launch buttons in the launcher that don’t do anything

  • Fixed OM-35847 Materials from Create failed to come across during Live

  • Fixed OM-36823 Live timeline doesn’t syn properly with Create

  • Fixed OM-36827 Create is offsetting geometry when live sync with 3dsMax

  • Fixed OM-37558 If you make an MDL other than omniGlass, then you lose omniGlass in the options list

  • Fixed OM-38059 Extra map parameters in MDL materials. Partial fix. They were moved, but still exist. They will be removed in the future.

  • Fixed OM-29904 Some native materials are not exported as MDLs

  • Fixed OM-38230 Linked and instanced asset causes crash when exported

  • Fixed OM-38799 Deleting meshes causes Create to crash

  • Fixed OM-39524 Deleting xform or actor from Create/View/Unreal while file is open in Max and Live fails to delete children.

  • Fixed OM-40118 Crash if export a usd with name “light shape” or “camera shape”

  • Fixed OM-39341 Max Opening a native 3dsmax file should reset default prim

  • Fixed OM-40634 Export UV’s with texcoor2f[] rather than float2[]

  • Fixed OM-36750 Close USD doesn’t clear the 3dsMax

  • Fixed OM-35656, OM-36691 3dsMax application load times with connector installed

  • Fixed OM-36160 Materials break if MDL and native materials exported together

  • Fixed OM-36402 Graceful fail Forest Pack Pro nodes are in 3dsMax

  • Fixed OM-36500 When re-exporting an USD makes MDLs if export option is set to default

  • Fixed OM-16743 Crash after canceling Mirror with Live Sync Opening

  • Fixed OM-32706, OM-37346 vMaterials that use opacity maps are invisible/ fail to compile in Create

  • Fixed OM-37421 Saving to read only location on Nucleus does not alert user

  • Fixed OM-40534 Fails to show grouped objects when Live, must reopen file

  • Fixed OM-41508 During live sync cameras come in with differing perspectives if the scene is Y up

102.2.2

  • Fixed bug exporting OmniSurface Preset materials

  • Fixed file specific export issues involving mesh

  • Fixed Vray export issue reported on forums. ( Partial ) Do not support some localized string characters.

  • Fixed case where Save USD to a mounted file caused a crash

  • Fixed handling of materials with same name, now duplicates are auto renamed to be unique

  • Fixed OM-20165 Export throwing a Read error for layer

  • Fixed OM-24399 View Project disconnecting when opening a new scene

  • Fixed OM-25829 Variants made in Maya would not always open in 3dsMax

  • Fixed OM-29725 Fixed Cursor for file dialogs

  • Fixed OM-35651 native Physical and Standard materials exported USDPreview Surface incorrectly

  • Fixed OM-34536 Materials Include Dependencies failed for specific USD

  • Fixed OM-35216 Crash for opening specific USD file

  • Fixed OM-35284 Max error with Live timeline scrub

  • Fixed OM-35792 Save USd dropped Materials

  • Fixed OM-35891 Create New View Project failed to export

  • Fixed OM-35976 Exception in script after exporting and opening max file

  • Fixed OM-36144 Destination MDL templates path had unexpected behavior.

  • Fixed OM-36484 Reexport of existing USD file broke materials

  • Fixed OM-36616 Kind not being exported

  • Updated Core material Library

102.1

  • Added 3dsMax 2022 support

  • Added MDL Distiller - Users can now edit and visualize (limited) an MDL from USD files as well as create MDLs from with 3dsMax. See 3dsmax Material documentation.

  • Added Forcing pure gray materials when VRay version check fails. (edited)

  • Added USD Python Bindings

  • Added - Support for opening usd files that have usd shade graph generated be Create

  • Improved material export of native materials

  • Improved additional Vray support on export

  • Improved lag in some Live sync conditions

  • Improved Vray export - No version up material names on repeated exports.

  • Improved VRayFastSSS2 correct units.

  • Improved bump amount matches better with VRay.

  • Fixed Embedded MDL failure for AEC project

  • Changed Export Option - Embedded MDL removed from UI and default to on. Script command available to control it.

    • Limitation - changed values on these material nodes may not work with save USD / Live USD.

101.2.9

  • Fixed an issue where some assets would have wrong position on export due to xform.

  • Fixed Export to multiple files failing in some cases

  • Fixed a bug where a new view project to disc would fail

  • Improved material transparency for native material export

  • Improved V-ray export support. Nodes added are Vray Bitmap , 3dsMax Blend, 3dsMax Standard Output

  • Other various bug fixes

101.1

  • OMNIVERSE® Toolbar replaces the Omniverse Panel

  • Improved OMNIVERSE® file browser

  • Support OMNIVERSE® View Projects for AEC

  • More native material types export to MDL

  • Vray to MDL on Export

  • Improved USD Preview Surface support for export and Open USD

  • Save USD

    • Known limitations - See General for details.

  • Import USD

    • Known limitation - See General for details.

  • Improved Instance support

  • General stability and bug fixes.

  • Client Library Updated

  • Core MDL library updated

2020.2.2 Hotfix

  • Client Library Updated

    • Fixed a bug that would sometimes (very rarely) cause data loss.

2020.2 Hotfix

  • Client Library Updated

    • Fixed a bug that would sometimes (very rarely) cause data loss if you got a disconnect while uploading a file.

    • Fixed a bug that would fail to download a file if it was an exact multiple of 1MB

  • New sign in dialog removes username field

2020.2 Point Release

Added Features

  • Added Support for 3dsMax 2021

  • Updated core material library

  • Live timeline scrubbing

  • Improved mesh triangulation for subdivision surfaces

  • USDA (Ascii) supported for local export

  • Updated latest OMNIVERSE® client library

  • Local export improved

  • General performance improvements

Bug fixes

  • Fixed issue with Live Sync stopping while working

  • Fixed issue with Live Sync check box that is always disabled

  • Fixed issue with Variant Live Sync controls breaking after changing them in View

  • Fixed issue with Live Sync connection requiring an extra export

  • Fixed issue when exporting over existing USD

  • OmniPBR_Opacity.mdl only exports when cutout map is used

2020.1 Point Release

  • Basic camera support

  • Model Variants

  • CSV Material Export

  • Bug fixes on material handling

Roadmap

Future features we are currently thinking about are as follows and in no particular order.

  • Improved Light support

  • Refined collaboration with other Omniverse Tools

  • Times sample attribute animation support

  • Pre and post script support