References#

  • RFC 2119 — Key words for use in RFCs to indicate requirement levels.

  • RFC 6749, Section 4.4 — The OAuth 2.0 Authorization Framework: client credentials grant.

  • RFC 7617 — The “Basic” HTTP authentication scheme.

  • RFC 7636 — Proof Key for Code Exchange (PKCE) by OAuth public clients.