User Interface

Project Menu

Menu Items

Description

Create New View project

Launches file dialog to set a path and project name for an AEC View Project

Set Existing Project

Launches file dialog to allow user to set currently opened max or USD to file to an existing AEC View Project

Close View Project

Closes connection to the AEC View Project. This will disable Publish to Project menu option

Max Omniverse Menu Learn more about the AEC Project Workflow on the Omniverse View Portal

USD Menu

Max Omniverse USD Menu

Menu Items

Description

USD

Menu for various USD Descriptions

Recent USD

Lists recently opened USD assets

Import USD

Imports USD Files to the current USD file

Open USD

User can open a USD file

Save USD

Save the changes only to the current USD file. Limited functionality with materials. Some Mesh edits and modifiers may trigger a material sync

Link to USD

Links an existing 3DS Max file to an existing USD. This allows a user to initiate a live connection without reexporting the USD.

Close USD

Closes the USD file and resets the 3DS Max file to a new blank scene.

Help Menu

Max Omniverse Help Menu

Menu Items

Description

Max Connector Documentation

Links directly to the online documentation

Get Support

Links to online Omniverse forums for support

Release Notes

Links directly to the online documentation release notes

About

Informs user of the version specific information of 3DS Max Omniverse Plug-In.

3dsMax Omniverse Toolbar

Omniverse Panel Connection

Option

Description

Connect to Omniverse

Connect or disconnect to an Omniverse Nucleus

Open USD

Opens a USD file locally or on a Nucleus

Save USD

Save the current USD file.

Import USD

Imports a USD file into your current project.

Export USD

Exports current project file as a USD.

Share USD

Copies the location of the USD Files, if on nucleus, this link is shareable with other permitted nucleus users.

Live Sync

Enables real-time “live” editing.

Participants

Shows the active participants in the current live session and which application they are using.

Create Variants

Creates a USD Variant container.

Settings

Opens the Omniverse Plugin Settings Panel. See Omniverse Settings for details.

Help

Links to this documentation.

About

Version and Technical Information about the Plugin.

Note

Known Limitations - 3dsMax Omniverse toolbar. When the toolbar is in a docked and compressed state on the right side of the app, the extra options arrow doesn’t reveal the cropped toolbar buttons, we believe this is a 3dsMax bug. Solution, re-dock toolbar to new position.

USD Export Browser

Max Omniverse Export Browser

Note

You can export to USDA (Ascii) format by hard typing the extension .usda on export if exporting to a local drive (not an Omniverse server).

Items

Description

Navigation Bar

Displays the path to the current directory or file the user has selected. Users can select any part of the existing path to directly access that par to the path.

Backward

Users can step to older previous paths.

Forward

Users can step toward current path selections.

To Parent Folder

Navigates to the parent folder, of the currently open folder.

New Folder

Creates a new folder/director at the specified location.

Refresh

Refreshes the content of the browser

Omniverse File Hierarchy

Users can navigate files on Omniverse servers or their local PC

Content

Shows the content in the selected part of the hierarchy

File Name

Set the name of the USD file you’re creating.

Extension Selector

Currently Omniverse exports USD (binary) files. (See Note Below)

Export Options

Max Omniverse Export General Options

General

Description

Export Type

Selects the asset type:

  • Prop: Assets that are non-skinned objects.

  • Prop Animation Clip: Simple property Animations for Props.

Export Options

Selects what to export:

  • All: Exports everything in the scene.

  • Selected: Exports everything selected in the current scene.

Default Prim

The name of the default prim for the exported file. World is the default prim in Omniverse.

Export Visible

Exports only visible nodes in combination with the current export selection.

Lights

Exports supported lights.

Cameras

Exports cameras in the scene.

Instances

Defines how to handle Maya asset instances on export. This option introduces new xforms into the hierarchy for compatibility.

Move to Origin

Exports the object as if it was normalized at world origin.

Up Axis

Controls the up-axis on export.

Also Save 3DS Max

Stores a copy of the 3dsMax file on the Omniverse Nucleus.

Max Omniverse Export Animation Options

Option

Description

Use Animation

Includes animation sequence in export

Start Frame

First frame to be exported from the animation sequence

End Frame

Last frame to include in the export

Step

Allows skipping of frames, use 1 for all frames

Max Omniverse Export Materials Options

Materials

Description

MDL Context

Includes materials on export or not:

  • Default: References the core MDLs when exporting MDL render context

  • Include dependencies: Copies MDL dependencies to the chosen directory. If no directory chosen, uses a default.

  • CSV Mapping File: Writes MDL references to existing location defined in the chosen .csv file

  • Material Swap(.csv): If Export MDL export option is set to Material CSV map, then the csv file to be used is defined here. This results in fewer files being exported.

USD Preview Surface Context

Exports the materials to a USD Preview Material render context as best as possible.

Max Omniverse Export File Output Options

File Output

Description

Batch Export

If checked, takes 1st level nodes in hierarchy and exports those as their own USD, then references them back to a main USD:

  • Payloads: Batch exports as USD Payloads.

  • Reference: Batch exports as USD References.

  • Preset: Predefined configurations of how usd files, materials and textures will be organized in directory structures. Refer to our usage documentation to learn more.

  • Props: The directory path where individual assets go during a batch export.

  • Materials: The directory path where materials go for a batch or individual export.

  • Textures: The directory path where textures go for a batch or individual export.

Note

The directory paths listed above can use tokens to configure the export paths. See usage here. File Output.

Max Omniverse Export Checkpoint Options

Checkpoints

Description

Description

Optional User Description for checkpoints.

USD Open and Import Browser

Max Omniverse USD Menu

To quickly get to a file, paste an Omniverse URL into the filename field and press the Enter or Open button.

Option

Description

Render Context

Choose the preferred method for displaying Materials in 3DS Max:

  • None: Materials will be ignored.

  • MDL: Imported materials will be opened, but limited in functionality

  • Preview Surface: Imported materials will display using USD Preview Surfaces.

Object Name Collision

Choose what to do if there are naming conflicts with Imported Objects:

  • Overwrite: Replace the existing object if in conflict.

  • Skip: Keep the original and discard imported objects if name conflict exists.

  • Modify: Adjusts names of imported object to avoid name conflicts.

Not displayed for Open dialog, only Import.

Material Name Collision

Choose what to do if there are naming conflicts with Imported Objects:

  • Overwrite: Replace existing materials if in conflict.

  • Skip: Keep the original and discard imported materials if in conflict.

  • Modify: Adjusts names of imported materials to avoid name conflict.

Not displayed for Open dialog, only Import.

Known Limitations

  • Import USD limitation: Does not currently collect imported materials. The original location of the materials will remain at same location unless the scene is re-exported.

Omniverse Settings

Max Omniverse General Settings

General Settings

Option

Description

Auto sign in on startup

If enabled, 3dsMax will automatically sign in with last known credentials on start up.

Echo Omniverse feedback in script Editor

If enabled, prints feedback to the 3dsmax Script Listener.

Verbose Log

If enabled, printed more detailed feedback about Omniverse during Live-Update.

Enable renaming for invalid and duplicate names

If Enabled, automatically fixes up names that are incompatible with USD, MDL, or Omniverse.

Display parameters on conversion of V-Ray to MDL

If enabled, allows the parameters to be user editable after the USD file is opened in Create. This could come at a performance cost in a large scene.

Materials Search Path

All users to add custom MDL search paths to pick up custom material templates or collections.

Max Omniverse Live Settings

Live Settings

Option

Description

Selection Mode

Defines the set of objects that are Live-Update connected

Live Transform Edits

If enabled, transform changes are Live updated

Live Material Edits

If enabled, material edits/assignments are Live updated

Live Camera Edits

If enabled, Camera transforms and parameters are Live updated

Live Light Edits

If enabled, Light transforms and parameters are Live updated

Live Timeline Edits

If enabled, scrubbing the timeline in 3dsMax will send the current frame as the USD file during Live update

Live Modeling

If enabled, modeling changes will be sent during Live Update